[0.8] How do I fix the error “error while loading shared libraries”?

applies to Scrypt, Scrypt PoW/PoS and SHA-256
branch 0.8

updated July 30, 2019, 4:04 pm

The Linux daemon is compiled for Ubuntu server 18.04 and is incompatible with other versions of Ubuntu.

The error message “error while loading shared libraries: libboost_system.so.1.54.0: cannot open shared object file” is triggered when you start the daemon in an unsupported version of Ubuntu.

You can fix the error by compiling a new daemon.
Compiling instructions are available under "Compiling" -> “How do I compile a daemon for Ubuntu server 18.04?”.

Share